Overview
Issues with Twitter integration may be experienced such as the Twitter handle is no longer authorized to capture incoming mentions, direct customer messages, or favorites sent through your Twitter account asking you to reauthorize your account.
Prerequisite
- To connect Twitter accounts in Kayako, you will need an administrator account with the 'Manage channels' permission.
Diagnosis
To receive or send tweets in Kayako, you'll need to authorize Kayako with your Twitter account. Once authorized, you can start to send and receive tweets through that Twitter account. However, there are times when Kayako may stop syncing with your Twitter account and the following error may appear:
Your monitored Twitter handle, {Twitter_handle_name}, is no longer authorized to capture incoming mentions, favorites or direct messages. Please visit your settings for this handle and reauthorize your account.
There are two (2) possible reasons why this problem would occur:
- Twitter integration was disconnected in Kayako.
- Kayako is undergoing maintenance or experiencing server issues.
If the integration is disconnected, it will show "connection lost" next to the Twitter account. Then, you need to reconnect it. If not, then you need to contact the support team for further investigation.
Solution
In order to re-authorize your Twitter account, you will have to do the following:
- Sign in to Kayako and go to the admin area.
- Under the 'CHANNELS' heading, click the Twitter link.
- Here, you'll see any Twitter accounts that you've already added. Hover over the Twitter account that you are getting the notice about and select Reconnect.
- You will be asked to sign in to your Twitter account to re-authorize Kayako. Enter your username and password.
- After successfully signing in to your Twitter account, click the Authorize app button.
- Once you've authorized Kayako for Twitter, you'll be redirected back to the settings page where the Twitter account will be listed. Should the problem persist, please reach out to the support team so we can investigate the issue further.
To reach out to the support team, follow these steps:
- Click the Submit a ticket button at the top or at the bottom of this page or click this submit a request link.
- Provide the details of the issue including the following:
- A reproduction video showing a simulation of the issue or testing. This will help us expedite the solution should there be a need to involve the infrastructure or engineering team.
- If you are allowing support to impersonate your account for troubleshooting purposes, please include an explicit approval on the ticket along with the email address of your Kayako administrator account.
Confirmation
After re-authorizing Kayako, you should no longer be seeing the error message and the "connection lost" next to the Twitter account.
You should now be able to send and receive tweets through this Twitter account again.