Overview
You can use Messenger to offer support in different languages by enabling multiple languages in Kayako.
Diagnosis
Kayako Messenger makes it easy for our customers to deliver a great real-time support experience. When you're communicating with customers around the world, it's important to be able to deliver a support experience that's tailored to their language preferences.
As with other localizable content in Kayako, the language displayed will depend on two factors:
- Which languages you've enabled from the admin area.
- Which of those languages the customer selects from the Help Center dropdown.
So to use the messenger feature in multiple languages, you simply need to enable the languages you want to use in the admin area. Then end-users will be able to see the languages you enabled and select them as desired.
Prerequisites
- To edit the messenger configuration, you will need an administrator account with the 'Manage channels' permission.
- To enable and disable languages in Kayako, you will need an administrator account with the 'Manage localization' permission.
- Check our supported languages table to make sure your selected language has Messenger support. Any language that supports Help Center Interface translation includes support for Messenger translations.
Solution
Enabling New Languages
- Sign in to the admin area.
- Click Localization on the sidebar under Customizations.
- In the Languages tab, hover over the language you want, and click the Enable link that appears.
- You'll see the language jump up to the 'Enabled' list at the top.
NOTE: If you need to remove one of your enabled languages, you can do so by clicking the Disable link next to it.
And that's it! Now the language you enabled will appear as an option when your users are selecting their preferred languages as well as in the messenger configuration.
Customizing the Greeting and Welcome Text
One important thing to note though is if you customize your Messenger greeting or welcome text, you'll need to provide your translations using the localization menu. Otherwise, your greeting will appear in your default language regardless of what languages your customer selects.
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Sign in and navigate to the admin area.
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Click Configure, under the Messenger heading in the sidebar.
- In the Customize tab, click the language drop-down menu.
- Type the translation in the respective language field and click Done.
- Click the Options tab, then click Save configuration.
You can find the steps in customizing messenger from the Enabling and Customizing Kayako Messenger article.
Testing
To test this feature after enabling multiple languages from the admin panel, follow the steps below:
- Go to your Help Center.
- Select the language you want to use from the drop-down menu.
- Then click the messenger bubble launcher on the lower right corner. You will see that the greeting and the home screen welcome text will display according to the language selected.