Overview
One of the most common issues with Brands within Kayako is the SSL certificates not working for custom domains. You may experience an issue where you have updated your SSL certificate but the website is still showing an expired SSL message like "SSL certificate has expired" or "Not Secure".
Diagnosis
Setting up an SSL certificate for a custom domain can be a little tricky, so first and foremost, you need to make sure that the directions provided in our help article on configuring custom domain and SSL certificate have been followed.
It's worth noting also that if you're updating or replacing an SSL certificate, we recommend doing this at least 24-48 hours before your current one expires to ensure a smooth changeover.
A few things that need to be taken into consideration also are:
- Validate if the SSL Certificate is from a trusted certificate authority.
- SSL Certificate is valid and has not expired.
- You need to get a new certificate if you use a custom domain, or get a new wildcard certificate to cover your entire domain (You cannot reuse your main domain's SSL certificate unless it is a wildcard certificate).
Using an online certificate checker tool can help to determine these pieces of information. If it fails any of these checks, then you will need to reach out to the company that issued the certificate for assistance.
On the other hand, if the certificate meets the criteria above, the next step is to remove and then re-upload the SSL certificate.
Prerequisites
- To configure the SSL certificate for a brand in Kayako, you will need an administrator account with the 'Manage brands' permission.
- You need a copy of the certificate as well as the private key.
Solution
NOTE: If you recently changed your SSL certificate and it's still showing the old certificate, you might need to wait for at least 24-48 hours for the changes to take effect. Otherwise, proceed with the solution below.
- Sign in to Kayako and go to the admin area.
- Click Brands from the left sidebar under CUSTOMIZATIONS.
- Hover over to the Brand you want to configure and click Edit.
- Scroll down to the Custom SSL section and clear the existing SSL certificate and private key.
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Click Save to save the changes.
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After clearing the SSL certificate and private key, copy the information from your source and add them back again. Hover over to the Brand you want to configure and click Edit.
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Scroll down to the Custom SSL section and add your SSL certificate and private key.
- Click Save to save the changes.
Confirmation
If the procedure is successful, you should no longer have an issue with your SSL certificate such as "SSL certificate has expired" error showing on your website, or the webpage is displaying errors stating "Not secure".