Overview
Issues with Facebook integration may be experienced such as customer messages sent through your Facebook account are no longer syncing with Kayako or are not being converted as conversations in Kayako.
Diagnosis
For any connected Facebook page, Kayako pulls in the messages and converts them into conversation posts. Or, if the customer already has an open conversation, Kayako will add the message to the existing conversation's timeline.
There are times when Kayako may stop synching your messages from Facebook to Kayako or vice-versa. It means that either new chat messages are not being converted into new conversations, or messages are not being appended to existing open conversations.
There are three (3) possible reasons why this problem would occur:
- Facebook is undergoing maintenance or experiencing server issues.
- Facebook integration was disabled in Kayako or the connection was lost.
- Kayako is undergoing maintenance or experiencing server issues.
One of the possible reasons for connectivity loss is described in the Troubleshooting Error When Sending Reply via Facebook Channel article.
Before troubleshooting the issue, check if Facebook is undergoing maintenance or experiencing server issues.
- Go to Facebook's status page.
- Check if there are any reported issues related to FacebookGraphAPI or if Facebook is undergoing server maintenance.
- If this is true, then you just have to wait until the issue is resolved. There's nothing we can do from Kayako to resolve this issue.
- If there are no reported issues, then proceed to the troubleshooting steps below.
Solution
To troubleshoot the issue, please follow these steps:
- Log into your Kayako.
- Go to the admin area and click the Facebook link on the sidebar menu under Channels.
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NOTE: Here you will see a list of the Facebook pages that have already been connected to your Kayako instance. If there is no page connected or listed, then you need to connect a Facebook page. Kayako won't be able to pull your Facebook messages if the page is not connected. Otherwise, proceed to step #3.
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NOTE: Here you will see a list of the Facebook pages that have already been connected to your Kayako instance. If there is no page connected or listed, then you need to connect a Facebook page. Kayako won't be able to pull your Facebook messages if the page is not connected. Otherwise, proceed to step #3.
- Make sure Facebook integration is enabled or connected.
- If it is disabled, it will appear under the "DISABLED" section on this page. Then, you need to enable it. Hover over the Facebook page and click Enable on the menu, as shown in the screenshot below.
- If the integration is disconnected, it will show "connection lost" next to the Facebook page. Then, you need to reconnect it. Hover over the Facebook page and click Reconnect on the menu, as shown in the screenshot below.
- If it's enabled and connected but you are still having problems synching your messages from Facebook to Kayako, proceed to step #4.
- If it is disabled, it will appear under the "DISABLED" section on this page. Then, you need to enable it. Hover over the Facebook page and click Enable on the menu, as shown in the screenshot below.
- Delete the Facebook page and connect it again. To delete, hover over the page link in the Facebook integration window and click Delete.
- To re-connect the page, refer to the Connecting Your Facebook Social Media Account With Kayako article.
Testing
After performing the troubleshooting steps above, try sending a test message using another Facebook account through your integrated Facebook page. The Facebook message will be forwarded to Kayako and you should be able to see it in the Agent area as a new conversation.
You may also try replying to the newly created conversation in the Agent area to see if the message will appear on Facebook. If yes, then that means your problem is solved!
To know how messages are synchronized between Kayako and Facebook, please visit the Interacting with Facebook Pages Through Kayako article.