Overview
If you have replaced or customized the email template codes or may have accidentally deleted it and you want to restore the original or default code, you need to paste the default code back into the templates. This article provides a copy of the default email template codes and how to restore it.
Diagnosis
You can customize Kayako’s email templates to match your brand’s look and feel. Email templates support placeholders that add dynamic content to your replies and notifications automatically. If you have customized these templates and somehow you would want to go back to the default ones, you would need to manually restore them by copying the code blocks below and pasting them back to the email template section in Kayako.
There is no feature in the email template section of Kayako that auto-restores the default codes.
Default Codes
The following codes are the default email template codes for the reply, notification, and satisfaction survey templates.
Reply
<div class="email-container kayako-mail-wrapper" style="font-family: Helvetica, Arial, sans-serif; font-size: 15px; line-height: 25px; margin: 0; padding: 0; color: #2D3138;">
<!-- Email Body : BEGIN -->
<div style="width: 100%;">
<div>
{{ contents|raw }}
</div>
{% if case.recent_public_post_history|length > 0 %}
<div>
{{case.recent_public_post_history|raw}}
</div>
{% endif %}
</div>
<!-- Email Body : END -->
<!-- Email Footer : BEGIN -->
<div class="x-gmail-data-detectors" style="width: 100%; font-size: 13px; color: #838D94; border-top: 2px solid #ddd; padding-top: 10px; margin-top: 10px; text-align: right;">
Sent with <b><a href="https://kayako.com" target="_blank" rel="noopener noreferrer">Kayako</a></b>
</div>
<!-- Email Footer : END -->
</div>
Notification
{% autoescape false %}
{{ contents }}
{{ footer }}
{% endautoescape %}
Satisfaction Survey
<table>
<tbody>
<tr>
<td>
{{ survey|raw }}
</td>
</tr>
<tr>
<td>
{{ contents|raw }}
</td>
</tr>
</tbody>
<tfoot>
{{ footer|raw }}
</tfoot>
</table>
Prerequisite
- To edit the email templates in Kayako, you will need an administrator account. No specific permission is required.
Solution
IMPORTANT: Please note that this process is irreversible. We suggest you keep a copy of your customized templates in case you want to restore them back in the future.
- Sign in to Kayako and go to the admin panel.
- Click Email templates under CUSTOMIZATIONS.
- NOTE: If you are supporting multiple brands, select the corresponding brand in the Brand drop-down menu.
- Go to the template you want to edit (e.g., the Reply template), delete everything in the box, and paste the default template code. (see template code in the section above)
- Click Save to save the changes.
Confirmation
After restoring the default template codes, all your replies, and notifications going forward will immediately use whatever the default template code contains. Any customizations previously done will be removed.