Overview
Triggers can be created to prevent spam emails (Russian spams are very common in Kayako) from being created as conversations in Kayako.
Diagnosis
A trigger may be configured so that the spam email is automatically moved to trash even before it reaches your inbox. This way, you would not have to deal with manually deleting the spam emails from your inbox.
The best way to combat Russian or Cyrillic-based spam in Kayako is to deploy a trigger that is configured to look for unique Cyrillic characters (б
, в
, г
, д
, ж
, з
, к
, л
, м
, н
, п
, р
, с
, т
, ф
, х
, ц
, ч
, ш
, щ
, а, э
, ы
, у
, о
, я
, е
, ё
, ю
, и
, and й
), which are mostly present in the subject line, and will automatically move them into the trash.
Also, you can block emails sent from Russian domains (.ru)
As mentioned above, this trigger will automatically trash conversations that met the conditions set within it. That said, if you received a high volume of conversations that match the rule's condition, you would see a high amount of conversations going into your Trash folder. You might want to do some manual clean-up from time to time.
Prerequisite
- To create a trigger in Kayako, you will need an administrator account with the 'Manage automations' permission.
Solution
- Log into your Kayako and go to the admin panel.
- Click Triggers under AUTOMATION.
- Click on the New trigger button.
- In the Rule Title field, add a descriptive title.
Note: It is essential to use a good naming convention to keep track of triggers.
- In the 'When these conditions are met' section, configure the following:
-
From the 'Select a condition' drop-down, choose Conversations: Subject.
-
From the next drop-down, select contains.
-
In the next blank field, enter the first Cyrillic character. (see diagnosis section for the list of characters)
-
- Click the Add a new condition link and repeat step 5 to include all the Cyrillic characters that need to be monitored. (see diagnosis section for the list of characters)
- Additionally, you can block or emails sent from a specific domain or from all Russian domains by adding the following condition with OR operator:
[Primary email contains .ru] - From the 'Perform the following actions' section, select Flow control: Trash a conversation, and click the Save button to create the trigger.
Confirmation
Each time a new message comes in containing any of the Cyrillic characters in the subject line, the system will automatically move these messages to the trash.