Overview
The Kayako spam filter checks for messages that can't be authenticated or verified, messages from disabled or blacklisted addresses, and messages considered as spam. If an email qualifies to any of these filters, then Kayako will automatically suspend the messages and stores them in the suspended folder. Kayako has pre-defined algorithms in the system that will catch these types of emails, but you can also manually add email addresses or domains to the blocklist.
Diagnosis
Kayako has a Spam Filter to help reduce spam generated conversations. The pre-defined algorithms in the system will catch the emails if they qualify as "spam" and move them automatically to the suspended folder. You can bypass this by adding the email address or domain in the safelist.
On the other hand, you can also manually add email addresses or domains to the blocklist. Users with email addresses or domains that match those in the blocklist will be prevented from registering an account and any incoming email messages from them will be suspended.
Prerequisite
- To edit any of the security and user registration settings, you will need an administrator account with the 'Manage system configuration' permission.
Solution
- Log into your Kayako and go to the admin panel.
- Click the 'User registration' link under SECURITY.
- In the Email blocklist box, enter email addresses or domains you want to blocklist (per line).
- To separate the entry of the email addresses and domains, you can either use a new line or use an asterisk (
*
) symbol as a wildcard to blocklist everything.
- Click Save when you're done adding the email addresses or domains.
Confirmation
New emails sent from email addresses or domains you have added to the blocklist will now go to the Suspended folder instead of being created as conversations.