Overview
Once you have your SLAs set up and configured, you can build automation to bring any overdue conversations to the immediate attention of your team using either monitor or trigger automations. This article provides instructions on tagging and increasing conversation priorities that breached SLAs.
Diagnosis
You could set up a trigger to take any conversation that breaches a target, bump it up to 'Urgent' priority, and add a 'breached' tag to make them super-easy for your support team to find. Speaking of which, creating views that display conversations that have breached, conversations that are about to breach, or just conversations subject to a specific SLA are all great ways to make it easier to meet your targets.
If you need help with the basics of building automations, check out our instructions on how to create triggers and monitors and our automation reference guide for conditions and actions.
Prerequisite
- To add a trigger in Kayako, you need an administrator account with the 'Manage automations' permission.
Solution
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Sign in to your Kayako and go to the admin area.
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In the sidebar, click Triggers to see the list of any triggers that have been created in your Kayako.
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Click the New trigger button.
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In the Rule Title field, add a descriptive title. In this exercise, let's say SLA breached.
NOTE: It's essential to use a good naming convention so you can keep track as you add more and more automations. -
In the Rule Settings section, we're going to leave Any selected, since we want it to apply to conversations from any source. You may select the appropriate channel as needed.
NOTE: Breached SLAs are system triggers. Selecting 'email' as the trigger will cause the rule not to fire since the breached SLA does not come through the email channel. -
In the 'When these conditions are met' section, from the 'Select a condition' dropdown, choose 'SLA: SLA breached'.
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In the 'Perform the following actions' section, from the 'Select an action' dropdown, select Conversation: Priority.
- From the next dropdown, choose change.
- From the last dropdown, choose Urgent.
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Click the +Add a new action link, and from the 'Select an action' dropdown, select Conversation: Tags.
- From the next dropdown, choose add.
- From the last blank field, type
breached
.
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Click the Save button to create your new trigger.
Confirmation
This automation will be fired every time a conversation breaches an SLA target. It will change the conversation priority to 'Urgent', and tag the conversation as 'breached'.