Overview
In Kayako, you can create a trigger that prevents non-administrative users (agent role) from changing the conversation assignment.
Diagnosis
For more control over who decides and routes conversation assignments, you can build automation that will limit which users can assign conversations. Using the automation below, you can prevent any user without administrator access or on someone on "agent role" from changing a conversation's assignee.
NOTE: To learn more about the different conditions and actions available when building automations, please visit the Building Automation Conditions article.
Prerequisite
- To add a trigger in Kayako, you need an administrator account with the 'Manage automations' permission.
Solution
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Sign in to your Kayako and go to the admin area.
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In the sidebar, click Triggers to see the list of any triggers that have been created in your Kayako.
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Click the New trigger button.
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In the Rule Title field, add a descriptive title. In this exercise, let's say Prevent Non-Admin To Change Assignments.
NOTE: It's essential to use a good naming convention so you can keep track as you add more and more automations. -
In the Rule Settings section, we're going to leave Any selected, since we want it to apply to conversations from any source. You may select the appropriate channel as needed.
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In the 'When these conditions are met' section, from the 'Select a condition' dropdown, choose 'Conversation: Assignee'.
- From the next dropdown, choose changed.
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Click the +AND button to add an AND condition.
- From the 'Select a condition' dropdown, choose Conversation: Updated by user role.
- From the next dropdown, select not equal to.
- From the next dropdown, select Admin.
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In the 'Perform the following actions' section, from the 'Select an action' dropdown, select Conversation: Assignee.
- From the next dropdown, choose revert to original.
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Click the Save button to create your new trigger.
Confirmation
Every time a non-administrative user (agent role) attempts to change the conversation assignee, it will automatically revert to the original assignee. This prevents any unauthorized change in conversations assignee which is helpful if you have implemented strict measures to keep conversations to whoever is assigned to it.