Overview
You have editing access to the templates that control the sign-up page and modify the form in your Help Center such as removing unused or unnecessary fields from it. If you want to modify how the sign-up page would appear to end-users, you may edit the template at any time.
Diagnosis
Templates are HTML documents that control how your content is presented in your Help Center. To make outstanding self-service easier to deliver to your customers, Kayako comes equipped with a powerful Help Center customization tool. From adding logos and color schemes to directly editing the HTML templates and CSS styles, you can use the customization tool to control every aspect of how your Help Center looks and feels.
Sometimes, you might want to remove unnecessary or unused fields from the sign-up form to provide ease and convenience to your customers or end-users. In this article, we'll walk you through the customization panel particularly editing your sign-up page template. In the example below, we will show you how to remove the "Your Twitter handle" field from the sign-up form.
To learn more about the Help Center customization tool and how to customize its appearance, please visit Customizing the Appearance of Your Help Center article.
Prerequisite
- To customize the appearance of your Kayako Help Center, you will need an administrator account with the 'Manage the Help Center' permission.
Solution
-
Sign in to Kayako and go to the Help Center.
-
Click the Customize button on the upper-right of the toolbar.
-
On the customization pane, click the Customize templates heading.
- From the Template drop-down menu, select the Signup template.
-
To remove the "Your Twitter handle" field from the sign-up form, add the following code snippet at the top of the existing code.
<style>
#signup>[for="twitter"]{
display:none }
</style>- The result should be similar to what you see in the image below:
- The result should be similar to what you see in the image below:
-
Click the Save button to save the changes.
NOTE: There is a Revert to default button close at hand if things start to go sideways.
Testing
- Go to your Help Center sign-up page (e.g., https://YOURDOMAIN.kayako.com/signup).
- Inspect the fields. You should no longer see the "Your Twitter handle" field from the sign-up form. The modified form should look like the image below.