Overview
When a user wants to chat or start a conversation through the Kayako Messenger, they will always be prompted to enter their email address to start chatting. The email address is required for authenticating their session in Kayako.
Diagnosis
The email address will always be required for authenticating a user's session when they initiate a conversation through the Messenger. If the messenger is being accessed through the Kayako Help Center, the user will be prompted to enter their email address, unless the user has signed in to the Help Center. This is the default behavior and there's no way around it.
If you have added the messenger to your website or app, the same behavior will be experienced by the user. But if you don't want end-users to be prompted to enter an email address when using messenger while on your website or app, then generate the web device token necessary for your development team to enable automatic identity verification. The details, including generating its token are available from within the Kayako admin area.
Solution
Accessing the Messenger through the Kayako Help Center
As mentioned above, users are required to enter an email address before chatting unless they have been authenticated by signing in to the Help Center. On the other hand, you can configure the messenger so that live chat can be offered only to users who are logged in to your Help Center. That way, the messenger will no longer require end-users to enter an email address when they initiate a conversation.
To do that, please visit the solution we prepared for you in the Restricting Messenger Display on Help Center article.
Accessing the Messenger through a third-party website or App
If you have added the Kayako Messenger to your website or app and you don't want end-users to be prompted to enter an email address when using messenger, then you can generate the web device token necessary for your development team to enable automatic identity verification.
To do that, please visit the solution we prepared for you in the Generating Messenger Token for Automatic Identity Verification article.
Confirmation
Restricting Messenger Display on Help Center - If you enable this option, live chat or messenger will be enabled only when a user has logged in to the Help Center.
Automatic Identity Verification - If you enable this option, end-users will no longer be prompted to enter an email address when using messenger while on your website or app.