Overview
Coupled with automation, Slack endpoints take advantage of Slack's incoming webhooks feature to enable you to post conversation information directly into a particular Slack channel. However, you may encounter an issue where Kayako would stop sending messages to your Slack channel.
Diagnosis
There are multiple possible reasons why this issue would occur such as:
- The Slack channel ID or password has changed.
- Changes to the configured automation that triggers the action (incorrect settings or rule conditions).
- System outages from either Kayako or Slack.
Prerequisite
- To create or manage endpoints in Kayako, you will need an administrator account with the 'Manage endpoints' permission.
- To add or manage triggers or monitors in Kayako, you will need an administrator account with the 'Manage automations' permission.
Solution
Typically, if there's a problem with the endpoint connection, you will see a message in the Endpoint section of your admin panel. The first thing you need to do is to check if there's an error.
To check your endpoint:
- Sign in to Kayako and go to the admin area.
- Click the Endpoints link on the sidebar menu under Integrations.
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Here you'll see the endpoints you have created in your Kayako instance.
- Check the endpoint in question if you see an error next to it as seen in the sample screenshot below.
- If there's an error, click it to see the details.
NOTE: If you see this type of error, this indicates that Kayako is unable to communicate with your endpoint for a few reasons (i.e., the Slack channel ID or password has been changed). If this is the case, you need to re-establish the connection between Kayako and Slack.
- Check the endpoint in question if you see an error next to it as seen in the sample screenshot below.
- Go to the Incoming Webhook Portal and follow the instructions there for creating a new incoming webhook.
Note: This step will require you to log in to your Slack account. You'll choose your destination channel when creating the webhook. - Copy the URL for your new webhook.
- Come back to Kayako and select your Slack endpoint to edit it.
- Paste the new URL into the Slack Webhook URL field and save it.
NOTE: Please find out more about endpoints at Sending notifications to external systems with endpoints.
If you don't see an error on the endpoint itself, check your automation configuration.
- Sign in to your Kayako and go to the admin area.
- In the sidebar, click Triggers or Monitors (depending on where you configured your automation) under AUTOMATION.
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Select the relevant trigger or monitor and examine the conditions and rule settings.
- NOTE: To learn more about creating automations with triggers, please visit the Creating Automations with Triggers and Monitors article.
If the steps do not address your issue (i.e., no error on the endpoint and your automation is properly configured), check to see if there's an outage on the Slack side. If yes, then you may need to wait until the outage is fixed.
If all else fails, submit a ticket to the support team so we can investigate further.
- Click the Submit a ticket button at the top or at the bottom of this page or click this submit a request link. If you already have an open ticket for this issue, please proceed to step 2.
- In your ticket, provide the details of the issue including a screenshot of the error if there's any.
- Write a short description of the issue and include information such as:
- The exact name of the endpoint.
- The exact name if the trigger or monitor.
- A reproduction video is preferred if available. This will help us expedite the solution should there be a need to investigate the issue further.
- If you are allowing support to impersonate your account for troubleshooting purposes, please include an explicit approval on the ticket along with the email address of your Kayako administrator account.
- Write a short description of the issue and include information such as:
Confirmation
If the issue is due to an endpoint connection failure, once you have re-established the connection, Kayako should be able to send the messages to your Slack channel.
Or, if the problem is due to the automation configuration, once you have fixed the configuration, Kayako should be able to send the messages to your Slack channel.